Segmentation fault when opening Coreform cubit on Ubuntu 18.04.5 LTS

Hi there,

I am trying open Coreform cubit version 2021.5 but I am getting the error below. Would anyone know how to solve this problem? The Coreform cubit that I am trying to open was downloaded from the website.

My system information:
Ubuntu 18.04.5 LTS

Thank you,

sudo ./bin/coreform_cubit 
[2021-08-30 08:47:22.294] [info] RLM session initialized
Error loading component:

Error loading component:

Error loading component:

Error loading component:

Error loading component:

Initializing cubit without using the sudo comment:

Segmentation fault (core dumped)

Make sure that the following packages are installed:

libgl1 (If graphics driver is not already installed)
libglu1-mesa (If graphics driver is not already installed)
libgl1-mesa-glx (If graphics driver is not already installed)

If that doesn’t fix the problem, please take a system call log with strace like this:

strace -o debug_cubit.txt coreform_cubit

Attach the generated debug_cubit.txt here please.

Also, you probably shouldn’t run coreform_cubit under sudo, some of our dependencies (like OpenMPI) really don’t like being root.

Thank you for the reply,

I tried both of your suggestions but I still get segmentation fault:

/home/Coreform/Coreform-Cubit-2021.5/bin$ ./coreform_cubit 
Segmentation fault (core dumped)
/home/Coreform/Coreform-Cubit-2021.5/bin$ strace -o debug_cubit.txt ./coreform_cubit
Segmentation fault (core dumped)

Please let me know if you have any other suggestions.


Please attach the generated debug_cubit.txt from strace. strace prints out all the Linux kernel calls that a program makes, that will help me diagnose your issue.

Apologies, see attached the debug_cubit.txt file.

Thank you,

debug_cubit.txt.csv (849.2 KB)

What graphics card and drivers do you have installed? The crash comes when coreform_cubit is sending a NV-GLX event, which is related to the nvidia drivers.

I am not an expert on Ubuntu. I used the command lshw. See the result below.

Does this help? Let me know if you prefer that I use another command.

~/Desktop$ lshw -c video
WARNING: you should run this program as super-user.
description: VGA compatible controller
product: NVIDIA Corporation
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:d5:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: vga_controller bus_master cap_list rom
configuration: driver=nvidia latency=0
resources: irq:202 memory:c4000000-c4ffffff memory:b0000000-bfffffff memory:c0000000-c1ffffff ioport:9000(size=128) memory:c5000000-c507ffff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

OK, so you’re using an nvidia card and drivers. Can you try updating your drivers please? The mechanism for doing that can be different depending on how you installed them, but you should be able to get them from the nvidia website:

Thanks for the reply. I don’t think that I will be able to update my driver. In the past, I have had lots of trouble with graphics cards on ubuntu and now that I have something that is working I prefer no change it.

Note that I am currently using Coreform cubit 2020.2 on Ubuntu and it is working fine.

Is there anything else that I could do to help, other than trying to update my graphics card?


It seems that due to the trouble you’ve had in the past that your setup is non-standard, not that there really is a standard when it comes to Linux, unfortunately.
You can look at Coreform 202x Segmentation faults (Ubuntu 18.04) for an example of someone else with a similar issue. I suggested that they use a Xephyr window, which is a way to host graphical applications in a custom environment on the same machine.