Error when exporting mesh as Exodus file

Hi,
I have installed the free trial version of Cubit on Mac, and created a large mesh with over1 a million hexahedral elements. When I export the model as Exodus (.e) file, the following error is shown:

Using Exodus API versions 8.03 and DB version 8.03 to export
Error. Trouble writing qa records.
Error. could not export data to a file

A similar but smaller model is exported successfully in old cubit 13.0 versions without any error.
I would appreciate it if you could kindly let me know how I can resolve this.

Thanks so much for your consideration!
Karim

Welcome @karim_gmSim!

If you’ve installed the free non-commercial version of Coreform Cubit, we limit the number of elements that can be exported to 50K. If you need to export more elements there are a couple options available to you:

  1. Request a 1-month trial license (free) from our website: https://coreform.com/products/trial/
  2. Send an email to support@coreform.com detailing your situation (high-level description of your analysis problem, circumstances around your problem (e.g. graduate student working on thesis)) and we’ll work to find a solution that works for you (e.g. temporary removal of restriction).

If you installed the 1-month trial version of Coreform Cubit there shouldn’t be any export limit, so in this case please send us an email at support@coreform.com with as much detail as possible.

Thanks!
Greg

Thanks so much Greg for your considerate reply! I appreciate it.

The version I am using (for academic research) is in fact the 1-month trial version. I apologize for my typo in the previous message, the number of elements is above 100 million. Does it mean that I need to buy a commercial version of the software?

Thanks so your help!
Karim

There shouldn’t be any licensing restriction for your export then. 100M is quite a few elements, you will likely need at least 128GB of RAM plus scratch space (or more RAM in lieu of scratch space). My workstation doesn’t have enough RAM + scratch to test exporting 100M elements, but I can take a look later.

It’s possible that you might need to specify which “flavor” of Exodus to export to… can you reply with the Exodus export options that you’re using (or, if not using the GUI, the commands)? I would recommend using the settings I’ve shown below (which are not the default).

image

Thanks so much Greg for your helpful point!. I was using the “Normal Format” and also was using " set large exodus file off". Apparently, this results in “set exodus netcdf4 off”, hence the error.

Based on your help, now I am using the commands below to export my models as Exodus and it works very well:

set large exodus file off
set exodus netcdf4 on
export mesh “./model.e” block 1 2 3 4 5 6 overwrite

May I ask how I will set a scratch directory for cubit? (If this requires me to open a new post, please kindly let me know).

Thanks so much Greg!
Karim