Windows 11 - Graphical Elements Won't Load

Hello,

I have tried to install Coreform Cubit on a Windows 11 machine but have encountered a serious issue. Everything seems to go fine until Cubit is installed, and I start it up. Once I start Cubit, many graphical elements will not load including missing icons and (most importantly) the editor GUI and tabs (command, history).

I tried installing with the 2022.6 and 2022.4 installers and encountered the issue with both installations. Am I missing some dependency, or is this a known issue? Any help would be greatly appreciated!

Hi James,

We are not currently testing Windows 11. Let me ask around here and see if anyone has made the upgrade.

Typically, the errors you describe happen when the GUI can’t load plugins properly. Would you try starting from the command line (either PowerShell or DOS command prompt) and run C:\Program Files\Coreform Cubit 2022.6\bin\coreform_cubit.exe.

Thanks,
Karl

When I start from command line it still does not load the graphical elements.

Right. What output do you get in the command prompt?

I do not get any output, it just starts the GUI with the missing graphical elements.

OK. Let’s try the following then. Let’s do this from the DOS command prompt because I can’t remember how to set environment variables in PowerShell off the top of my head.

set CUBIT_VERBOSE=5
"C:\\Program Files\Coreform Cubit 2022.6\bin\coreform_cubit.exe" > cubit_output.txt

Then send the cubit_output.txt file to me at karl@coreform.com

Do you happen to have any other software installed on your system that might have changed your PATH?

Thanks,
Karl

Specifically, I remember that TecPlot uses VTK and modifies the user PATH envionment variable. This mean that Cubit ends up finding the wrong version of VTK. We work very hard not to modify the user PATH so we don’t cause problems for others.

Thanks,
Karl

This is a fresh install of Windows 11. I don’t believe anything I have installed so far (MS products mostly) would change PATH variables.

Just sent the output file. Let me know if you need anything else.

One of our developers here has Windows 11 machine. He was able to download and start Cubit 2022.6 correctly. It is not something inherent in Windows 11. (which is a relief!)

Karl

The error messages from the output file indicates that Cubit is unable to load any of the plugins.For examaple,

[error] LoadLibraryW error: C:\Program Files\Coreform Cubit 2022.4\bin\cfplugincomp.ccl %1 is not a valid Win32 application.

I’m still back to my idea about anti-virus programs. Are you running McCaffee or some other anti-virus software that might have come installed with a new Windows 11 machine?

Here is something else to try. Let’s try importing Cubit in a python script just to see if this works. Place these commands in some file test.py

import sys
sys.path.append(r"C:\Program Files\Coreform Cubit 2022.4\bin")
import cubit
cubit.init([])

Then execute this with the version of python installed with Cubit

'C:\Program Files\Coreform Cubit 2022.4\bin\python3\python.exe' test.py

You should get a message about initializing RLM, a bunch of garbage, and then the Cubit banner.


                   CCCCC    UU   UU   BBBBBB    IIII   TTTTTT
                  CC   CC   UU   UU   BB   BB    II      TT
                  CC        UU   UU   BBBBBB     II      TT
                  CC        UU   UU   BB   BB    II      TT
                  CC   CC   UU   UU   BB   BB    II      TT
                   CCCCC     UUUUU    BBBBBB    IIII     TT  tm
                            MESH GENERATION TOOLKIT
                                      FOR
                   PRE-PROCESSING OF FINITE ELEMENT ANALYSES

Hi @jbtompkins,

We have seen a similar case where the user was running a VM that didn’t have a full Windows install. It was missing some of the required Windows libraries and returned the error “is not a valid Win32 application.”

Is there any chance this machine is a minimal install of Windows 11?

Thanks,
Karl