Speeding up webcutting

Dear Cubit Folks,

I am meshing an extremely simple geometry: just a cube. I however need 12 webcuts in the x,y and z directions to ensure that I will have nodes at certain desired locations in the cube. This leads to a total of 36 webcuts. The process is extremely slow, taking many many hours. Is there any way to speed up the webcuts.


There are a couple of things you could try in addition to the other suggestion.

  1. You may want to try turning off the undo support. You can either type “undo off” at the command line or click on the little blue flag in the toolbar.

  2. Make sure that the imprint and merge options are checked off in webcut panel. BUT make sure you do a separate merge operation after all the webcuts to give you a conformal mesh model. This will also take a couple of minutes typically.

I agree with Corey that your times are not what we typically see. I took a brick and did the 36 webcuts and it took 353 seconds. That is still longer than I would like but it is not hours. It does look like there is an n^2 type algorithm in there someplace because it does take longer as the number of volumes increases.

Another way to create the volumes from scratch (like Roshan’s approach) is to use the copy repeat option available in Cubit 13.2 as follows

brick x 1
volume 1 copy move x 1 repeat 12
volume 1 to 13 copy move y 1 repeat 12
volume 1 to 169 copy move z 1 repeat 12

This took about 46 seconds (this still nearly as fast with undo on) on my system and may be a reasonable approach to modeling your problem if the blocks are all of the same size.

– Karl

You guys are right. I was doing an imprint and merge after each webcut and hence the insane times. I still take around 15 mins and not ~300s. Would you suggest that I remove imprint completely and just stick with a merge all after all the webcuts?

I am also using “webcut volume all” for each webcut (instead of webcutting just the relevant volumes). That could explain why my webcuts still take a longer time than yours.

If you are building the model up from the webcuts everything should line up properly for merging and you shouldn’t have to imprint. The merge should be adequate. You will need to verify that. You can try something like setting the visibility to transparent or wireframe and typing

draw surface with not is_merged

That should just draw the exterior surfaces in this case and nothing on the inside would be drawn.

It sounds like your machine is a little slower than mine.

I also used the webcut vol all approach. So that is not the cause of the difference. It is probably processor or memory constraints. How dense a mesh are you looking to put on these volumes? If you get a pretty dense mesh you will need to make sure your machine as a lot of memory.

Another hint if you are meshing really large models, you can set “graphics off” and then do the meshing. Do a “graphics on” when the meshing is complete to see the updated model. This avoids trying to update the graphics as you go and actually will save you some significant computational cycles especially on a slower machine.

– Karl