Running on Apple Silicon

Hi: Just installed Coreform on a Mac running 13.2.1 with an M2 Pro chip and rosetta installed. Upon opening, I “agree” and then app crashes. Subsequent opening of Coreform crash immediately. I tried a fix for Cubit crashing, namely in the Coreform directory I typed:

xattr -r -d *

but I got a long list of permission denied. Any suggestions?

Joe Kelly

Please open up a terminal window and run /Applications/, then report the full terminal output here.

Thanks for the help. Here is the terminal output:

(moose) ~ % /Applications/
usb support disabled
libc++abi: terminating with uncaught exception of type std::bad_alloc: std::bad_alloc
zsh: abort /Applications/

Unfortunately we don’t have any M2 Macs to test on and it’s unlikely that Cubit will work. It should work on an M1 Mac.

Hi Scot. Actually Cubit 16.08 does run on my M2 Mac (after I run xattr -r -d *). I haven’t used it enough to make sure all functionality is there but it doesn’t crash immediately upon opening it like Coreform does.


That’s Sandia Cubit, correct? Unfortunately, we build Coreform Cubit with a different toolchain than Sandia Cubit does, so there’s no guarantee that one will work where the other does and vice versa.

Hello Again. I should also have said that Cubit did immediately crash until I ran the “xattr -r -d *” command in its directory. Coreform is behaving similarly with an immediate crash. Perhaps there is a similar fix?


That’s unlikely, the crash you’re seeing is in core C++ libraries because you’re on a different processor architecture then the one Cubit is built for.

Thanks Scot. I’ll try some real meshing cases with Cubit 16.08 and let you know if it runs correctly. I does open and I can build geometry.


I too am facing some troubles running cubit on Apple M2 system.
I am using cubit version 2022.4 and it’s running fine on the GUI.

But It’s showing some architecture incompatibility error when I try to run a script from the terminal.

here’s a screenshot of the error.

Has anyone encountered similar issues, and if so, do you have any solution for it?



I am having the same issue as Athira. From what I understood, (which is called when trying to import cubit) has been precompiled for x86_64 architectures and can’t run on arm64 architectures. I am correct ? If so, is there a way to get a version of that is compatible with arm64 architectures ?

Thank you very much,