Open large .cub file fail


I face an open error saying: “the file you are trying to open doesn’t exit” when I try to open a mesh file (*.cub) with size of about 10G. I am sure the mesh file is perfectly fine, but I don’t know how could I open it successfully.

Any suggestion helps.


Also, when I tried export the large mesh to an exodus file, Trelis crashed.


Are you using a version of Trelis older than 15.1? There is a new HDF5 .cub file format in Trelis 15.1. The problem with the old .cub format is that the table of contents can only read out 4GB from the beginning of the file. The file format has that limitation. With a 10GB file, its very likely that the last section in the file starts beyond the 4GB barrier. This problem was solved when going to the HDF5 format in Trelis 15.1.

Yes. I use the Trelis Pro 15.0.

OK, I will update my Trelis version to 15.1, thanks for your help!



I use Trelis 15.0 now and I would like to update it to version 15.1, but I do not find a way to update in Trelis’ GUI. Could you tell me how could I update to Trelis 15.1?

Thank you.