Missing sides in sidesets?

Hi, I’m trying to export both node sets and side sets from Cubit, but there appear to be missing entries in the exported Exodus II file. There is a mismatch between the number of sides listed in the GUI and the number of entries in the .exo file.

Here is how I’m creating the side sets:

sideset 30 add surface 1 34 11 35 10 37 9 38 12 2 40 41 43 44
sideset 30 name "external_boundary_faces"
sideset 31 add surface 29 30 31 32 33 36 42 wrt volume 1 both
sideset 31 name "topo_faces"
sideset 32 surface 29 30 31 32 33 36 42 patch center 0 0 0 outer_radius {outerRadius}
sideset 32 name "topo_inner_faces"

Here are the entries from the Cubit session:
Name Id Side Count
external_boundary_faces 30 16966
topo_faces 31 93708
topo_inner_faces 32 78616

The counts are all significantly smaller when I look at the *.exo file:

netcdf southern_alps_mesh_lev1a {
	len_name = 256 ;
	time_step = UNLIMITED ; // (0 currently)
	num_dim = 3 ;
	num_nodes = 738697 ;
	num_elem = 4367621 ;
	num_el_blk = 1 ;
	num_node_sets = 3 ;
	num_side_sets = 3 ;
	num_el_in_blk1 = 4367621 ;
	num_nod_per_el1 = 4 ;
	num_side_ss1 = 1099 ;
	num_df_ss1 = 3297 ;
	num_side_ss2 = 148 ;
	num_df_ss2 = 444 ;
	num_side_ss3 = 680 ;
	num_df_ss3 = 2040 ;
	num_qa_rec = 1 ;
	four = 4 ;
	len_string = 33 ;
	num_nod_ns1 = 8485 ;
	num_nod_ns2 = 46963 ;
	num_nod_ns3 = 39040 ;

Sorry, I haven’t matched up each sideset with the proper name, but the number of sides is significantly smaller for each sideset in the Exodus II file, while nodesets match up perfectly. Any idea what the problem might be?

p.s. I also tried all the options for the Exodus II output format – Normal, Large File, NetCDF4, and it makes no difference.

Hello @charlesw,
i wasn’t able to reproduce this behaviour yet. Could you please share the .cub or the geometry and the journal file for this so that we can take a look at that.

Hi @Norbert_Hofbauer,
I wasn’t able to duplicate it with a simple example either. Am I allowed to attach large files in this forum? The .cub file describing the geometry is over 800 MB.

You can use https://transfer.coreform.com/ to upload your file. You just have to post the download link afterwards.

Hi @Norbert_Hofbauer ,
I’ve put together a tarball with an example. The tarball is at:
Southern Alps example
It contains:

  1. southern_alps_mesh_lev1.jou: Main driver file.
  2. southern_alps_1materials_bc.jou: File defining BC (including sidesets/nodesets).
  3. southern_alps_geometry_3materials_r2a.cub: File describing the geometry.

Thanks very much for your help!

Hi @Norbert_Hofbauer,
Unbelievable. I just ran the example to double check, and now it seems to be working correctly. I wonder if the issue is that I was deleting and adding nodesets/sidesets during my session. The only other difference is that I left out the smoothing step in the example (which takes a while to run). Sorry for the confusion. I will continue and see if I run into any more problems.

Hi @Norbert_Hofbauer,
After further research, it’s the cleanup command that seems to mess things up (this is before the definitions of sidesets/nodesets, though). If you uncomment the cleanup command in the lines below, I believe you will get the same issue. I haven’t tried this in a simple example yet to see if it also happens then. Also, note that the smoothing command doesn’t cause the problem.

# ----------------------------------------------------------------------
# Do one round of smoothing.
# ----------------------------------------------------------------------
cleanup volume all
# volume all smooth scheme condition number beta 2.0 cpu 5
# set debug 91 on
# smooth volume all


Hi @charlesw,
thanks to your geometry i was able to reproduce this.

It will take some time to investigate this. I don’t have a solution to this issue yet, i hope you can continue with your mesh even without the cleanup

Yes, I’m leaving out that step for now. This mesh is an initial iteration – I will refine it later using the Exodus sizing function option. I just hope that remesh doesn’t cause the same problem, because I use that a lot.