Importing MCNP files to Export Cad files

I have a MCNP code of a reactor made of hexagonal latices, that I can successfully run in MCNP. Now, to utilize the mcnp2cad feature that Cubit provides, I hoped to import my mcnp file to export a cad file using Cubit.
When I go to import the MCNP file, I let it load, I figured it takes a while for complex geometries, but when all things are done and loaded nothing pops up in the viewing window. I searched up and down different Cubit documents, their YouTube, and this forum, and found nothing that helped me resolve my issue.

Has anyone had any success using the mcnp2cad feature? And if you did, is there documentation on it?

I’m looking for help on how I might accomplish this.
Thank you!

Update: I tried another MCNP file one that is just very simple. It loaded quickly and it made a sphere with my mcnp model inside the sphere. So I am certain Cubit can take MCNP files, but I just don’t understand why this reactor doesn’t work.

Update 2: I managed to get the reactor to load Cubit occasionally will crash due to insane RAM usage (it created nearly 850,000 volumes), however, I noticed the reactor doesn’t load correctly. Cubit does not create the lattice layout correctly. The baby lattice does not get cut by the mother or grandmother universe, nor does it place the universes in the lat=2 layout that MCNP has. I’m not sure if cubit can support universes with lattice type 1 or 2 yet, but maybe in the future.

Cross-sectional XY View in Cubit I turned off some viewing to see the cross-section.

Cross-sectional XZ View From Cubit

Cross-sectional XY and XZ View From Vised Ignore the Shading errors Vised is way too old.

Hi Adam,
Sorry for the delay in answering this. Here’s the documentation for the feature:

I’ll have someone else respond with more detail reacting to your model soon.

Hi @Adam,

Thanks for trying out this feature! I’m not certain why the lattices aren’t being clipped by the containing cells. That’s pretty odd. There are tests for hex lattices in the mcnp2cad repository that load as expected in Cubit 2024.03.

Are there perhaps fundamental differences in the use of hexagonal lattices from how they’re used in your geometry that might help us to create a simplified example of this error in translation?

Also, out of curiosity, when you say that nearly 850,000 volumes were created do you mean that the final model contained that many volumes or that the volume ID count got that high by the end?

Hopefully we can get to the bottom of this soon!



For the 850,000 volumes, I did mean the final model from cubit volume ID got that high, not a total amount of volumes, and figured that was why it kept crashing and took forever to load.

I see that it worked for the test file, but I can’t help but notice the test file doesn’t have trees of universes like a grandmother (core), mother (assemblies), and baby (pins). Also on the test how are you filling latice with itself? I see you are filling the lattice with universe 1 but the fill is also u=1, MCNP would call it a void to fill the gap. Let’s say you did define a universe and it was an infinitely long cylinder made of mat 1, and surrounding that cylinder was mat 2 for an infinite amount. MCNP would take the height constraints of the mother matrix and contain the defined universe to its heights and constraints. What I noticed with the original file I used it did not do that. It simply let it be infinitely long rather than match the grandmother’s height. I tested a simple hex lattice assembly.

Here is what it looks like in VISED.

Here is Cubit’s output:
I actually could not get an output with this file, every time the graphics get turned on the application auto closes.

Here is the input file for the assembly. I converted it to a .txt to upload onto the forum.
HexLaticeTest.txt (2.1 KB)