How do I change my product key

I downloaded 2021.5 and registered the product key it to a demo license.

I now have a floating license, which is associated with a different product key. I cannot use Cubit when it loads, which makes me believe I need to change the product key.

I have un-instaled/re-installed with no success. How can I change this?

Can you give us a screenshot of the error you get when you start up Cubit? Also, please attach any files that are in your <installation directory>/bin/licenses directory.

There’s no errors, but everything is greyed out. I cannot even open a file.

What operating system are you running on?

I am operating on windowsx64

I cannot upload my license file in this forum

Please open up a command prompt and execute the following commands:

cd "C:\Program Files\Coreform Cubit 2021.5\bin"
coreform_cubit.exe > C:\Users\<username>\Documents\cubit_output.txt

Please attach the generated cubit_output.txt

this forum does not like txt files, so i changed the extension to jou… ughcubit_output.jou (8.5 KB)

Your license is checking out just fine. Was Cubit working normally before? It looks like the installation is corrupted, it’s unable to load component libraries. How did you uninstall and reinstall?
I’d be happy to get on a Zoom call with you to diagnose this issue.

You know… I have the Sandia version of Cubit installed on my machine as well… I wonder if there is something muddying up the components.

I used windows add/remove to uninstall.

Should I uninstall all instances of Cubit on my machine and restart it?

BTW scot, it looks like you’re on the invite list for a meeting with myself, Matt and Greg at noon EST. We can chat more in there if that’s good with you =)

I uninstalled my other Cubit installs and it worked.

All right, great! It should be fine to have multiple Cubit installs on the same machine as long as they’re not in the PATH environment variable.

So I am having issues again, I tried to modify my python environment variables and now it will not load. Here is the output. cubit_output.jou (11.6 KB)

The output says that Python is loading fine, the problem is that it can’t initialize OpenGL. Can you try running these commands?

cd "C:\Program Files\Coreform Cubit 2021.5\bin" -nographics -prompt Cubit

That should load you into a Cubit command prompt. If that prompt comes up successfully, we know it’s not a Python problem.
Usually on Windows there isn’t a problem with OpenGL since it’s usually installed on the system already. Are you running via Remote Desktop or in a virtual environment?

Wow… I would’ve never expected that. I just updated my RTX drivers, so I will roll them back and see how that works. Thank you!

This has been racking my brain today. I have uninstalled and reinstalled cubit and the video drivers… I have even hard-set the program to use the nvidia drivers.

still I get the same result.

And this was working before, right? That’s bizarre. Is the output from Cubit the same as well?

Definitely worked the other day. Still OpenGL Issues. Going to circle back with my IT department again today and see what we find.

[2021-11-05 07:53:54.267] [app_logger] [debug] has_feature: feature_id = 3
[2021-11-05 07:53:54.267] [app_logger] [debug] has_feature: feature_data->valid = 0
[2021-11-05 07:53:54.267] [app_logger] [debug] has_feature: feature_id = 2
[2021-11-05 07:53:54.267] [app_logger] [debug] has_feature: feature_data->valid = 0
[2021-11-05 07:53:57.053] [error] Could not find ARB attribs
WARNING: Unable to create OpenGL context. Check your OpenGL installation.

It was my python environment variables.
“Could not find ARB attribs” got me thinking, and when I checked there was an older path called on my EVs which did not exist anymore, I updated and am good for now. :thinking: