Exporting meshed body without webcuts

I have been working with Cubit Learn 2020.2 and have noticed that when exporting a body where I had to use a webcut to successfully hex mesh the body, the body gets imported in Mecway as two bodies instead of one. I have tried both Abaqus.inp and I-DEAS.unv with the same result, except the inp brought the material along but the unv did not. The file was originally imported into Cubit as an stp file, then webcut, then meshed.
I would appreciate understanding how to export only the recomposed body properly meshed so this does not happen. I’m new to this software so I may have missed something.

1 Like

One key difference between Cubit and Abaqus, is that when Abaqus performs a webcut (aka “partition”) the resulting volumes are “connected” through shared geometry. You could say that these volumes are continuous and a conforming mesh would be generated across these volumes.

In Cubit when we say “webcut” we mean it - we cut the geometry as though you’d used scissors. This results in separate geometric entities that are not connected - they are discontinuous. This allows you to build non-conforming meshes on these entities. If you want the geometries to be continuous, resulting in a conforming mesh, then you’ll need to “merge” them together - often after first imprinting them.

Here’s an example:

## Create Base Geoemtry
cylinder radius 1 height 4
cylinder radius .5 height 2
move vol 2 z 3
unite vol all
compress ids

## Webcut into three disconnected volumes
webcut volume 1  with sheet extended from surface 3 
webcut volume all with plane from surface 5

## Mesh Un-Merged Geometries
surface 4  scheme circle 
surface 11  scheme circle 
surface 5  scheme hole rad_intervals 3 
mesh surface 4 5 11 
mesh vol all

Notice how we have three geometries:

And how the meshes are disconnected:

If we instead imprint and merge we will have three connected volumes (Abaqus calls these “cells”) that will result in a continuous mesh

delete mesh

imprint vol 1 2 3
merge vol 1 2 3

surface 8  scheme circle 
surface 7  scheme hole rad_intervals 3 
mesh surface 7 8

volume 1 redistribute nodes off 
volume 1 scheme Sweep  source surface 7   sweep transform least squares 
volume 1 autosmooth target on  fixed imprints off  smart smooth off 

volume 3  redistribute nodes off 
volume 3  scheme Sweep  source surface 8    target surface 9   sweep transform least squares 
volume 3  autosmooth target on  fixed imprints off  smart smooth off 

volume 2  redistribute nodes off 
volume 2  scheme Sweep  source surface 9    target surface 4   sweep transform least squares 
volume 2  autosmooth target on  fixed imprints off  smart smooth off 

mesh volume 1 2 3

1 Like

I see what you’re doing, but I thought I did that. I did the webcuts via the Item wizard, under Prepare Geometry, and “Imprint and merge after Webcut” was checked, so I thought merging was done. I noted that the elements and nodes at the site of the webcut seem connected, and the problem solves OK in MecWay. BTW, I have not used Abaqus, but MecWay allows both inp and unv input for mesh importing.
So, since I did check to imprint and merge after webcut, it seems to have imprinted, but not merged, at least in terms of acting like a single body. Is there some other step I need to do?