Cubit Undo Error


I am facing an error while clicking undo option in cubit 2020 version. The error is mentioned below.
I welcome your suggestions to rectify this issue.

ERROR: Cannot undo inside an undo group.
Close undo group, then undo.

Hmmmm… thanks for bringing this to our attention. Can you describe your actions (which GUI commands) immediately prior to this error?

Had you previously executed a geometry command that failed?

A work-around is to type “undo group end” at the Cubit prompt. This will close the undo group and you can continue from there. However, be aware that doing an undo at that point will attempt to do an undo back to where the undo group started. You may end up with un-doing more than you anticipated. Save your model prior to executing an undo at this point.

As mentioned above, any help you can give us in reproducing the error is appreciated.

@gvernon the GUI command which was executed just prior to this error was modify>surface>tweak>target surface. After executing this command and when undo was tried the above error has happened.

@karl. Thanks for this info. I will try this option next time. But since I am new to cubit software, i would like to know more insight about the “undo group” command. Tried to explore about this in cubit documentation. But I didn’t get more info. Can you kindly brief me what exactly does this undo group command contribute to the undo operation.

1 Like

Cubit is primarily command driven. The Cubit command language is a pretty powerful language. In addition there is a comprehensive python interface to Cubit.

Everything in the GUI generates a command or sets of commands to complete a single operation. Those commands get echoed to the command line.

Operations that require multiple commands are wrapped in “undo group start”/“undo group end” pairs. My suspicion is that some operation is throwing an exception and skipping the code that should have added the “undo group end.” That is why I asked about the geometry operation error.

I have this same problem. It appears to be triggered by a corruption of the underlying geometry. Sometimes I can continue working with the geometry, but other times every subsequent command throws this error message:

ERROR: Encountered an uncaught exception 'Attempted get_and_step from empty DLIList
'. Command failed.

I cannot find any documentation for the “undo group start / undo group end” commands in the manual. I am not using them. Can you point to documentation on them?

The undo group start and undo group end commands are used internally and are not documented for external use. That said, if you wanted to implement undo in your own script, there is nothing that would stop you from using the undo group commands.

If you can save and give us the .cub5 file, we could use that to debug the problem.

I have been unable to reproduce the problem with non-proprietary geometry. I’ll keep trying if I have time.

Here is a simple case that reproduces the problem.


brick x 4

cylinder radius 1 z 5

subtract volume 2 from volume1 # Note the error here (missing the space between volume and 1

# I suspect that the error throws an exception and the exception handling does not close the undo group.

webcut volume 1 with plane xplane offset .000001


This is likely just one example that throws the exception.

The undo error actually happens on the command before you the undo group.

A fix for this bug has been submitted to Coreform Cubit and will be available in the next release.

1 Like