Cubit installation errors in Ubuntu 18.04 LTS

Dear experts,
I have tried to install Coreform Cubit

by uploading .gz archive on Ubuntu 18.05. However, I haven’t found instructions about how to install Cubit in the terminal.
I have these files:

I don’t know how to proceed.

Best regards,

You should get the latest downloads from There’s a .deb installer there that should install everything automatically for you.

Thanks for your reply, Sir. I managed to install it. However, I don’t know how to start it. Is there any manual or any tutorial to use it from ubuntu?

Best regards,

The user manual is here:
The tutorials are here:
Answers to the “Frequently Asked Questions” are here:

The error you’re showing can occur when you either don’t have a graphical environment (you only have a terminal) or your graphics aren’t configured correctly. If you don’t have a graphical environment, you can use Coreform Cubit from the terminal only by passing the flags -nographics -prompt Cubit, like this:

coreform_cubit -nographics -prompt Cubit

If you do have a graphical environment, then you can take a system call log like this;

strace -o debug_cubit.txt coreform_cubit

Please attach the generated debug_cubit.txt to this post and we’ll help you figure out the issue. If you don’t have strace, you can install it with

sudo apt-get install strace

Thanks for your reply Sir,
I have already tried with coreform_cubit -nographics -prompt Cubit and it asks me the licence

I tried to follow for offline activation, however, the activate tab does not appear in my window (maybe due to Coreform Cubit learn version).
Regarding the second command strace -o debug_cubit.txt coreform_cubit
I have attached the resulting file (in pdf version since .txt is not allowed)
debug_cubit.pdf (341.3 KB)

Best regards,

The graphics error is this:

connect(4, {sa_family=AF_UNIX, sun_path=@"/tmp/.X11-unix/X0"}, 20) = -1 
ECONNREFUSED (Connection refused)
close(4)                                = 0
getsockopt(4, SOL_SOCKET, SO_SNDBUF, [0], [4]) = 0
setsockopt(4, SOL_SOCKET, SO_SNDBUF, [65536], 4) = 0
connect(4, {sa_family=AF_UNIX, sun_path="/tmp/.X11-unix/X0"}, 110) = -1 ENOENT 
(No such file or directory)

That means that Cubit is attempting to connect to a X11 socket (that’s your graphics display) and the connection is being refused. Are you connecting to this machine via SSH? You may need to configure X forwarding, or there could be a permissions issue.

For a Cubit Learn license you will need the graphics to work in order to activate.

Thank you for your reply, Sir.
I managed to run Cubit GUI application through Xephyr.

1 Like