Coreform 2021.3 Fedora Fails to launch


I get the following failure on launch of Coreform Cubt 2021.3

/opt/Coreform-Cubit-2021.3/bin/coreform_cubit: /opt/Coreform-Cubit-2021.3/bin/./ version `Qt_5.15.2_PRIVATE_API' not found (required by /usr/lib64/
/opt/Coreform-Cubit-2021.3/bin/coreform_cubit: /opt/Coreform-Cubit-2021.3/bin/./ no version information avail
able (required by /usr/lib64/

I have QT5 qt5-devel-5.13.2-2 installed if that helps

Hi @makeclean, this is happening because your development Qt libraries are getting loaded in before our Qt libraries and they are conflicting. Do you have the environment variable LD_LIBRARY_PATH set to include your Qt installation?
You can take a system call log with strace -o debug_cubit.txt ./coreform_cubit, and attach the generated debug_cubit.txt here. That will help us debug how the libraries are being loaded incorrectly.

Ok, if I put LD_LIBRARY_PATH="" before it, it runs fine

Great, glad to hear it.

Ok new error, my coreform learn 2020.2 licence isnt valid, and asking for another licence gives me another 2020.2 licence?

Can you attach the license file and rlm_diagnostics.txt in bin/licenses please?

Cat of the license file

HOST cubit-learn ANY 5053

CUSTOMER CubitLearn1 isv=csimsoft port=443 password=7s6ndp7q55sg6mxp[adavis@J0818 ~]$ cat /opt/Coreform-Cubit-2021.3/bin/licenses/rlm_diagnostics.txt
RLM Diagnostics at 03/25/2021 13:44

RLM version: 14.1BL3
RLM platform: x64_l1
OS version: 5.10.19-200.fc33.x86

ISV name: csimsoft
Hostname: J0818
User: adavis
Working directory: /home/adavis


    RLM_LICENSE=<not set>
    RLM_NO_UNLIMIT=<not set>
    RLM_PATH_RANDOMIZE=<not set>
    RLM_PROJECT=<not set>
    RLM_QUEUE=<not set>
    RLM_ROAM=<not set>
    RLMSTAT=<not set>
    HTTP_PROXY=<not set>
    csimsoft_LICENSE=<not set>

RLM hostid list:

    7f0100 7085c2b1c3b4 7085c2b1c3b2 9a2ee6e8ba7b 525400c8f88d 525400c8f88d ip= ip= ip= 

License files:

rlm_init() parameters:
1: /opt/Coreform-Cubit-2021.3/bin/licenses
2: /opt/Coreform-Cubit-2021.3/bin/coreform_cubit

Local licenses which can be checked out:

Client Cached Licenses (only the highest version # shown):


In license file /opt/Coreform-Cubit-2021.3/bin/licenses/cubit-learn.lic
      (customer "cubitlearn1" server at:


In license file /opt/Coreform-Cubit-2021.3/bin/licenses/remote.lic
      (server at: 5053@cubit-learn)


Roaming Licenses:


That HOST cubit-learn ANY 5053 line isn’t supposed to be in the license file. When I connect to the Cubit Learn server and get a license file I don’t get that line, and I’m connecting and logging in successfully on Windows and Ubuntu with 2021.3. Could you try deleting that license file, and then entering cubit-learn into the activation dialog as the Product Key? That should get you the right license file.
If there’s a problem with writing the license file, the permissions on bin/licenses may not be correct. Try changing the permissions like this: sudo chmod -R 777 bin/licenses.

Hi I still get failed to checkout features from licence file

@makeclean There’s a small percentage of our users that can’t log into our cloud server for the Cubit Learn license. Instead you can use our free trial: That uses a different licensing scheme that doesn’t have this issue.

Not quite the same is it, a 30 day trial or 1 year of academic use?

Screenshot from 2021-03-30 21-56-19

Again, I presume 2020 and 2021 use the same cloud lookup, for me 2020 can connect fine. I presume I can have ‘as many’ cubit learn licences going at once? one for 2020 and one for 2021?

I am also interested in the response to this question. I have a similar problem, but on Win 10. I was running Cubit 2020.2 using the cubit-learn license. The version set up for me to download when I started out was 2020.2, but I noticed there is a link to a new download page, that has 2021.3. I downloaded that and installed, and the learn license worked, and I went back and forth between 2020.2 and 2021.3 last night. Today, however, only 2020.2 will start. 2021.3 will not start, and gives no message…just won’t initiate. Wondering about the same question if you can have two different versions of Cubit Learn on the same computer using the same license?