Difficulty with sweep mesh

I’m trying to make a swept mesh of a planar spring (see Volumetric Meshes).

I’ve created virtual partitions on the upper surface and am using a “many to one” sweep definition.

I can create a nice coarse mesh on these upper surfaces:

And I set my sweep options like this:

But it seems like the sweep mesh is having a tough time getting the sweep’s to be perpendicular (see skewed edges below):

Here’s the Trelis file if it helps debug
SweepIssue.trelis (582.8 KB)

Well, it looks like I fixed it after some tinkering:

Longer story is that I had tried all these sweep options on the original geometry (thickness = 0.25), and all resulted in skewed mesh. I then scaled the geometry by 4x (thickness = 1.0) and just tried the last scheme I used on the original geometry (the “Advanced” option). Seeing that it was still skewed I submitted the above question. Only later did I go back through every mesh option to test.

Just as a side note, Greg, translation of swept solids to U-splines does not support many to one swept meshes, as they cannot in general be represented as a tensor product between a 1d and a 2d spline. You will need to combine those source surfaces into one virtual surface after they’ve been meshed but before the sweep is performed if you’re planning on building a U-spline on that mesh.

We do plan to handle many-to-one sweeps sometime later this year.

1 Like

@caleb Follow-up question.

If I mesh this part per your advice, wherein the top three surfaces are meshed with pave scheme, the U-spline builds fine:

But if instead I use hole scheme for the outer and inner surfaces (highlighted), it fails:

Literally, the only thing I swapped out was the surface mesh schemes. Thoughts?

Well, I may have found the culprit for this one – memory supernova. I moved over to my PC – 24GB RAM + 31 GB SSD swap space.


Starting to swap…

Pressure is rising…


Compare this to the “all pave” scheme, here’s the max memory usage – which occurs at completion of build uspline from mesh

Here’s a zip with the files you’ll need to replicate: PlanarSpring.zip (230.6 KB)

Greg, as of yet we haven’t been creasing the U-splines that we create from swept solids to ensure that they are locally linearly independent. I’m putting in a fix for that, which helps with this error; now instead of simply crashing the program, it fails to build the U-spline in the U-spline algorithm. I will pass this on to @luke to take a look at why that is happening and what can be done to fix it.